1

I've an issue with email notifications sent from the server in that the content has some characters replace by '=' if the email client used is Microsoft based, e.g. Outlook, Hotmail. The following approaches have not helped solve the issue

Setting newline in the tools_communicate.php file

$this->email->set_newline( "\r\n" );

updating config.php to include

$config['email_newline'] = "\r\n"; 

defining different charsets in the head meta tags

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"> 

Any suggestions appreciated, Thanks!

  • Hrmm, do you have a staging/development copy of the application? I can suggest debug routes to see what raw data is being sent, and hopefully determine if it's an EE/server issue or a client issue, but it might break things for a minute. – jrothafer Jun 27 '16 at 12:40
  • Thanks for your reply. I was using MX Notify to send the email upon trigger by member group updates. I've just solved the issue by changing the MX Notify settings to send as plain text. – Christian Rochford Jun 27 '16 at 13:08
  • Cool, glad you got it! If you have the stack points to answer your own question and accept the answer, that would be appreciated and will possibly help others who may have this issue. – jrothafer Jun 27 '16 at 13:11
0

Search among various resources led me to believe the issue was caused by misinterpretation of line ends by microsoft powered mail clients (outlook, hotmail). No issues were observed in e.g. gmail or yahoo. As none of the above approaches worked the easiest option was then to set the mail to be plain text rather than html via the settings in MX Notify, the plugin used to trigger sending the mail notifications.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.