0

There are lots of places used global variables like "APPPATH" or "PATH_THIRD"

$path = ($native) ? APPPATH.$type.$pkg_name.'/' : PATH_THIRD.$pkg_name.'/';

I am having trouble with the $path value as it returned null. So I want to figure out where to set APPPATH variable?


Context:

In extensions.php, EE try to load modules. However, $path returns null

enter image description here

enter image description here

Thanks guys!

  • You should not have to set these constants - if they're empty then something else is wrong. In what context are you encountering this error? – Derek Hogue Jun 24 '16 at 15:09
  • @DerekHogue Thanks Derek! I have modified the question. This error is encountering when I try to migrate the current EE application to a new server. EE seems like cannot find the path to load extensions. – Fangzhou He Jun 26 '16 at 23:36
0

It looks like you're using a custom path to your third party add-on folder. My guess is that you have not updated $config['third_party_path'] to reflect the path as it exists in your new server environment.

  • OMG! It's working now! What I did is I modified the variable $env_config['third_party_path'] and $base_url in config/config.master.php. Thank you so much!! Derek! I have been struggling with this for 2 weeks. You saved my ass! – Fangzhou He Jun 27 '16 at 23:57
  • Can I ask one more question? The homepage and backend cms are showing perfectly. But when I click any link, it goes to the default server 404 page. Is it because of rewrite module, folder permission or something else? @DerekHogue – Fangzhou He Jun 28 '16 at 0:19
  • I fixed the 404 not found issue. The problem is the misconfiguration of .htaccess file in /html folder. I will post my one in here for others. Anyway, thank you so much, Derek. It's a huge help! – Fangzhou He Jun 28 '16 at 7:30
  • <IfModule mod_rewrite.c> <IfModule mod_negotiation.c> Options -MultiViews </IfModule> RewriteEngine On # Redirect Trailing Slashes If Not A Folder... RewriteCond %{REQUEST_FILENAME} !-d RewriteRule ^(.*)/$ /$1 [L,R=301] # Handle Front Controller... RewriteCond %{REQUEST_FILENAME} !-d RewriteCond %{REQUEST_FILENAME} !-f RewriteRule ^ index.php [L] </IfModule> – Fangzhou He Jun 28 '16 at 7:31

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.