0

I am having trouble figuring out how to get my paragraphs to wrap in < p >< /p >

Need to implement p tags inside < content > element: http://www.free-times.com/arts/rss_arts

Using EE v2.7.2

1 Answer 1

0

Whereabouts is the content coming from? If it's in a WYSIWYG field, check the source to see if it includes <p> tags within the markup. If it does these should be output to your template.

The alternative might be to place a <p> tag in your template with the correct output block inside, e.g. <p>{body}</p>

5
  • { body } does not output p tags from the WYSIWYG field, only < /br > tags
    – lbjw
    Jul 5, 2016 at 20:34
  • When I have a story opened, I notice there is a "Formatting:" option that is defaulting to "Auto < /br >" How do I change this?
    – lbjw
    Jul 5, 2016 at 20:37
  • @lbjw is it possible for you to upload a screenshot? I think that's an option you can change in a drop-down in the Admin panel.
    – Andy
    Jul 6, 2016 at 9:10
  • Hi Andy, thanks for your help. I figured out where to change the text formatting setting: Admin > Channel Admin > Channel Fields > Body This has fixed the original issue. However, now I am realizing that the exp:xml_encode tag that wraps around the body tag is stripping out <p></p> tags. Do you have advice as to how to allow <p> tags inside the exp:xml_encode tag? <code>{exp:xml_encode}{body}{exp:xml_encode}</code>
    – lbjw
    Jul 6, 2016 at 13:14
  • disregard -- realized I need to swap out the xml_encode tag for <![CDATA[{body}]]>
    – lbjw
    Jul 6, 2016 at 13:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.