2

As Stripe is upgrading TLS to v1.2 soon, how do we update Store to use the later version?

https://stripe.com/blog/upgrading-tls

Is it as simple as updating the Omnipay Stripe gateway code to a later version such as the one below I just found?

https://github.com/thephpleague/omnipay-stripe/releases/tag/v2.4.0

Thanks

  • I would also be interested in the answer to this if one ever comes... or have you managed to get to the bottom of it yourself? Thanks! – Dan Kingsley Nov 9 '16 at 11:14
  • I would third this query. Seems off that there has been no updates from Store/Dev Demon on this – Cole Henley Nov 18 '16 at 11:43
3

When it comes to supporting TLS 1.2, generally this is a server-side change, not a script-based change. So there's no action needed on DevDemon's part. Simply ask your host if they support TLS 1.2.

(Also, Store does not use Stripe's PHP library - they make more "bare-metal" calls to the API.)

You can test it yourself by following Stripe's notes here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.