0

The front end registration form on my client's site takes the info and even acknowledges success - and the admin gets notified. But the info isn't getting into the db/ee back end anymore.

This registration form has been working OK for years, the rest of the site is OK as well.

The form uses User 3.4.5 which is no longer supported by Solspace.

The site was recently moved to a new server - en masse with the rest of my hosted accounts.


My server admin looked at this and here's what he got when he turned on error reporting. I have no idea how to use this information.

A Database Error Occurred Error Number: 1366 Incorrect integer value: '' for column 'last_activity' at row 1 INSERT INTO exp_members (group_id, username, password, salt, ip_address, unique_id, join_date, email, screen_name, time_format, url, location, occupation, interests, language, last_activity, bday_d, bday_m, bday_y, aol_im, yahoo_im, msn_im, icq, bio, profile_views, timezone, signature) VALUES (4, 'mobin', '42b3f050b4c607c33200dde2ab4f3df36ea3b7b35dc26b283055f6e03ed600912a722257daf584162a46c7ab818ef727bd455cb6eb033840e3192e3066aee0d3', 'm0)ByGfjPC>\'sA=$j6>NAX\"QU?,M8XghPKF(/\"@uc\.N=T-v,I\'@K$RaaD=uf-uE>yV,SCRbBb#~AxGOC0OscBE%:3i?6~F]EnEl.}C(&3vB?#/7)I!S:~Qh\'zs,', '123.63.124.188', 'f8f835d49114da34eabf03cc60d807a7adda72b2', 1474251848, 'mobin.xavier@idologic.com', 'Mobin Idologic', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '', '') Filename: third_party/user/mod.user.php

0

Sounds like it might be a system path issue somewhere. Check your config file and other system settings. Try turning on error reporting, level 2 (show errors to all) and try a registration. See if any errors report back. The obvious thing you changed was migrating to another server. Is the php version the same? php configuration the same?

| improve this answer | |
  • My server admin looked at this and here's whart he got when he turened on error repostrting – Steve VanHove Sep 19 '16 at 12:56
0

The problem turned out to be mysql wasn't in strict mode on the old server, it was on the new one, so we disabled that and everything was fine again. :)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.