0

I've been trying to get SSI to work with EE, I can see the SSI code in the source but from some reason in EE it's not parsed, can anyone help with this issue?

I don't want to enable php on the page or use php includes.

I'm using SSI to include css and js assets. SSI are much faster then php include or EE templates.

  • Please, update your question. What are you using for SSI? – Robson Sobral Sep 20 '16 at 13:02
  • @robson: updated. – UmbrellaTech Sep 21 '16 at 14:05
0

I am 99% sure this is not possible. We just tried to do something similar in EE2 (you didn't specify what version of EE you are working with).

We got SSI working in .html and .php but could not get them working for any page that was handled by EE, regardless of template type ('static' didn't work for example) or whether PHP was enabled in the template.

It looks to me like CodeIgniter Security is preventing their execution. We just end up seeing the SSI code in the browser source.

  • Yes, I'm using EE2, it's so bizarre because the page goes trough Apache after EE parsing is complete, nothing should interrupt with it. "AddOutputFilter INCLUDES html php" should take care of it. I hope someone will be able to help. – UmbrellaTech Sep 21 '16 at 17:17
  • As an experiment (I wouldn't recommend deploying it) you could look at /system/codeigniter/core/Security.php around line 39 and 40. – AllInOne Sep 22 '16 at 14:59
  • doesn't this function called only on inputs ? or calling xss_clean ?, this does look like something the will prevent the ssi from working. – UmbrellaTech Oct 2 '16 at 23:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.