0

I'm using freemember on a user registration form and custom fields are not being passed to the member profile on registration.

I've tried both standard m_field_id_22 and freemember member_newsletter field names but neither are getting saved and the database is logging a value of null.

Any thoughts on solving?

1

Are you running the latest version of Freemember? Are you sure your custom field names are correct? Your code?

Ok, your code was not formatted properly..

{exp:freemember:register form_class="form form--standard"  error_handling="inline" return="account/register/thanks" required="first_name|last_name|email|company|address_1|city|postcode" error_delimiters='<span class="error">|</span>'}
<fieldset>
<h3>Do you want to request a trade account?</h3>
<div class="form__group form__group--inline">
{field:trade-account-yes}
<label for="trade-account-yes" class="form__label">Yes</label>
{error:trade-account-yes}
</div>

<div class="form__group form__group--inline">
{field:trade-account-no}
<label for="trade-account-no" class="form__label">No</label>
{error:trade-account-no}
</div>
</fieldset>

<fieldset>
<div class="form__group">
{field:accept_terms}
<label for="accept_terms" class="form__label form__label--required">I have read and agree to the <a href="/terms-and-conditions">Terms and Conditions</a></label>
{error:accept_terms}
</div>
<div class="form__group">
<button type="submit" class="btn">Continue</button>
</div>
</fieldset>
{/exp:freemember:register}
| improve this answer | |
0

Okay - this was resolved. Was fiddling with MX Notify which was terminating the write to custom fields when you try and send an email. Testing via Ajax was stopping me see the response.

Thanks for time and response on this everyone (in forum and via Slack)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.