0

EDIT 10/21/2016 - the original question is right below this edit.

User Anna_MediaGirl suggested that I reuploaded the files to make sure none was missing. Sadly, it didn't worked out and the error is the same. I double checked the config.php to make sure I was addressing the database correctly. The same info was used on ee_wizard, and the result is positive even on the suggested and optional requirements, so I believe everything is OK with my hosting service.

I'm sure I'm missing something here. Could it be the fact that it is running on a subfolder from my domain? The system path in admin.php is set as './system', is this ok? Or do I need to change it since I'm not in my public_html's root?

Important to notice, this is running perfectly on localhost. The only changes in the install I did was a .htaccess with the following lines to remove the index.php from the URLs. The problem continues if I remove the htaccess file.

RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?/$1 [L]

I'm sorry if some of my questions sounds dumb. Like I said, I'm not exactly a developer, but very interested in EE.


ORIGINAL QUESTION

I asked this question on EllisLabs' forum but am asking here as well, hope you don't mind.

Fact is I'm new to ExpressionEngine. My first run on EE was a freelance job, and apparently everything is fine. The install on my computer works fine (using Wampserver64) and the agency that hired me for the job had no problems uploading the site to the client's server.

Now I'm working solo on a new project, and trying to upload it by myself on my shared hosting. I followed all of the User's Guide direction to upload it, except for moving the system folder, for the sake of simplicity. The EE Wizard tells me my host is ok. I imported the database, did change the parameters on config.php to match the original database settings, granted all the permissions to files and folders.

However, when I try to access the admin.php I get the following message:

Error: Unable to load the requested class: functions

Since my client haven't decided on the domain yet, i'm running it on a subfolder of my portfolio, that is:

http://iconoclasta.com.br/heloee/

Please note that I'm not a developer. I work as a webdesigner for almost 10 years mostly with HTML and Bootstrap, so my skills on database management and back end development are inexistent.

Hopefully some one can help me with this? I'm pretty sure there's a begginer's mistake somewhere. I've been trying to find out the problem in the last 3 days and decided to call for help.

I'm using core 3.4.3 and no plugins or modules, only the vanilla core install. Any other information I need to provide?

Thank you very much!

  • Try reuploading all your files to the server. Sounds like something didn't upload correctly. – Anna_MediaGirl Oct 21 '16 at 14:07
  • thanks, i'm reuploading as I type. I'm worried because I already did it a few times. I even tried a clean install on the server, but it didn't worked as well. I'll update as soon as it's finished. – Daniel Sousa Oct 21 '16 at 15:57
  • Nope, still getting the same message. I watched the whole upload process (circa 2800 files, ugh) and none were missing or broken. – Daniel Sousa Oct 21 '16 at 17:30
0

So, I found a solution in EllisLabs forum: the functions.php file was being deleted by my server. In the link below, the file was located at system/expressionengine/libraries/Functions.php. Since the topic covered version 2.9.3, in my case the file was located at system\ee\legacy\libraries

However, the same solution applies. Changing

return eval('?'.'>'.$str.'<?php ');

to:

return eval('?>'.$str.'<?php ');

Now I can access the admin.php. The site is still broken, but at least this was solved :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.