1

Solspace Importer has stopped working with cron, but will work manually.

Apologies for the vague information but I'm really struggling to fix this. If there's any place I should be checking for issues, please let me know.

The setup:

  • EE2 2.10.1 and Importer 2.2.5
  • importing 3 files from local server (which are pulled from an external server)
  • files are UTF-8 with CRLF line endings
  • files are large, so batch importing is triggered via cron
  • due to the nature of the data, with each import previous entries need to be deleted and new entries created (this means channel entry IDs are getting very high. eg 1774926)

The cron automated batch processing has been working for over 6 months. And now imports can only be triggered by a manual import from the control panel.

Batch processing has stopped before, but after a manual import, the batch processing seems to work again. Does this indicate some sort of cache issue?

I've checked with webhosts who set up the cron for me, they say nothing has changed. I've also contacted the people supplying the feed, who also say nothing has changed.

Any help appreciated.

  • Have you tried importing manually? This would take Cron out of the picture and let you see if the importer generates any errors or is successful. – stuartmcd69 Nov 3 '16 at 2:29
  • Yes. Manual imports work fine with no errors in the import log. If there's anywhere else to check for errors, please let me know. – user1365655 Nov 3 '16 at 9:47
  • To confirm. You used the same data the Cron is supposed to use. You need to see the Cron because that will have the URL it's supposed to query. When you have the Cron URL copy it and paste it into a browser and see the results – stuartmcd69 Nov 3 '16 at 10:34
  • I've just copy and pasted the Cron and Batch Processing URLs and it does trigger the batch processing (however there does seem to be irregularities between import profiles. Results for one says "Import Location: cp", whereas the other "Import Location: cron"). I've asked webhosts for confirmation of cron settings. But why would they stop working if they worked for the last 6 months? To run the imports manually, I've been clicking the "run now" via the Importer in the control panel. – user1365655 Nov 3 '16 at 11:47
  • There are numerous reasons why this can stop. Check the server logs as a matter of urgency. Cron failures should log something. – stuartmcd69 Nov 4 '16 at 1:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.