0

I am desperately trying to make my Freeform (free version) to confirm to my HTML of my site. Here is the mess I have now so you see what I mean:

<!-- Contact Form -->


        <form class="contact-form row" method="post">


            <div class="col-md-6 col-sm-6 form-group">
                <input type="text" id="input_name" name="contact-name" class="form-control" placeholder="Name*" required/>
            </div>
            <div class="col-md-6 col-sm-6 form-group">
                <input type="email" id="input_email" name="contact-email" class="form-control" placeholder="Email*" required/>
            </div>
            <div class="col-md-12 col-sm-12 form-group">
                <input type="text" id="input_phone" name="contact-phone" class="form-control" placeholder="Telephone"/>
            </div>
            <div class="col-md-12 col-sm-12">
                <textarea placeholder="Comments" id="textarea_message" name="contact-message" rows="6"></textarea>
            </div>

            <input type="submit" id="btn_submit" formaction="mail:info@mannachurch.org" class="btn btn-default" value="send"/>

            <div id="alert-msg" class="alert-msg"></div>



            {exp:freeform:form
                        form_id="1"
                        required="name|email"
                        recipient1="Manna Church|info@mannachurch.org"
                        recipient_template="contact_form"
                        notify_user="yes"
                        user_email_field="user_email"
                    }

                        <p><label>Choose Recipients</label><br/>
                            <select name="recipient_email" />
                                {freeform:recipients}
                                <option value="{freeform:recipient_value}">
                                    {freeform:recipient_name}
                                </option>
                                {/freeform:recipients}
                            </select></p>

                        <p>
                            <label>{freeform:label:name}</label>
                            {freeform:field:name}
                        </p>
                        <p>
                            <label>{freeform:label:email}</label>
                            {freeform:field:email}
                        </p>


                        <p>
                            <label>{freeform:label:subject}</label>
                            {freeform:field:subject}
                        </p>


                        {if freeform:captcha}
                            <p>Please enter the word you see in the image below:</p>
                            <p>{freeform:captcha}<br />
                            <input type="text" name="captcha" style="width:140px;" /></p>
                        {/if}

                        <p>{freeform:submit}</p>

                    {/exp:freeform:form}

        </form><!-- Contact Form /- -->

Go to http://www.reachoutcelebration.com and scroll to the bottom to see what I mean. What am I doing wrong? EE newb desperately looking for help, let me know if this code is too much or not clear enough.

2

The {exp:freeform form} will create the form tags for you. Once inside you aren't required to use the {freeform:field:xxx} tag, you can just use the typical input syntax. I'll include some code below for reference.

                {exp:freeform:form
                form_id="1"
                inline_errors="yes"
                required="name|email"
                return="/thank-you"
            }
                    <span>* = Required</span>
                    <input type="text" name="name" placeholder="Name*">
                    {if freeform:error:name}<strong class="error">{freeform:error:name}</strong>{/if}

                    <input type="text" name="email" placeholder="Email*">
                    {if freeform:error:email}<strong class="error">{freeform:error:email}</strong>{/if}

                    <textarea name="user_message" placeholder="Questions/Comments"></textarea>

                    <input type="submit" name="submit" value="Submit">

            {/exp:freeform:form}
| improve this answer | |
  • Great! I managed to configure something similar. However, I cannot get the form to email specific users. The email submissions show fine in the freeform dashboard and they "say" that the are being sent to the recipants I want. Nevertheless, I've changed the recipiants to email three different accounts, same issue. The accounts show no record of being emailed from my form, but the freeform dashboard shows them recorded fine and says they got sent off, any suggestions? – Greg Nov 13 '16 at 16:08
  • In the settings for that form make sure "Notify Admin" is set to Yes. Then in "Admin Email Notification Email Address" you can specify the email addresses you're trying to mail out to separated by commas. If that's not working check Outgoing Email under Settings in EE and set another email address as the outgoing address. Sometimes the server will think you're an outsider spoofing the domain and it won't let emails through. Email is a pain. – Michael McGhee Nov 13 '16 at 18:28
  • Email IS A PAIN. I've similiar problems making wordpress sites. 1.) I made it so all outgoing emails go to specific emails. It goes to that email fine. However, it keeps going into the spam folder. 2.) I went ahead and put gmail SMTP for gmail and port number. But now the emails are going to the spam folder of the account. Right account now, BUT not in the inbox where I want it. I have "PHP mail" selected, so I tried putting it in "SMTP" and no luck. It doesn't send the email then. – Greg Nov 14 '16 at 16:30
  • The reciever gmail account that I am using is giving me emails with errors saying that it's not authenicated. Not sure why since I in creds for the gmail server via "Outgoing Email" – Greg Nov 14 '16 at 16:33
  • OKAY- I got it working, it seems like a temp fix though (not sure I'm utilizing all the perks of this add-on correctly). So after all that work on the outgoing server settings. I have this: SMTP settings/port for gmail(stmp.gmail.com port: 465), Protocol: PHP mail and I've kept the rest to stay the same as from before. The problem appeared to be fixed from me telling my gmail account that this is NOT spam. However, it still doesn't appear to be authenticating. BUT IT WORKS EUREKA. Any more ideas on how I can get gmail to read it as an authenticated email? – Greg Nov 14 '16 at 16:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.