0

My site loads at a sluggish 5 seconds. I've made the images the smallest I can without loosing too much quality. It was at 4.1 seconds, which wasn't great, but I was happy with it. Would adding channels to the mix lower load time? Right now, I think I can get by with none. This is a free version of expression engine with only one free add-on. Website is reachoutcelebration.com

Any suggestions would be appreciated.

1
  • 1
    I'm voting to close this question as off-topic because it isn't about eecms. – Robson Sobral Nov 13 '16 at 19:23
2

It isn't eecms' fault. Just open the source code and refresh it. Even without cache, it's almost instantaneous.

There's too much third-party content. And take a look at you HTML. Maybe some broken tag is delaying that waterfall of javascript files.

6
  • What do you mean by third party content? I only have one Add-on and vimeo video in the whole site. Thank you for responding to my post. – Greg Nov 14 '16 at 16:04
  • There's a lot of requests to GoogleMaps API. Really, really a lot. Just take a look at your browser network tool. There's a lot of jQuery and plugins too, but GoogleMaps is still the worst part. I believe you jQuery plugins are waiting for the map to finish loading. So, you need to fix that. – Robson Sobral Nov 14 '16 at 17:22
  • I'm sure those came with this HTML, which I purchased. Do you have any idea on how to fix that aside from simply disabling it? – Greg Nov 14 '16 at 17:33
  • 1
    You need to run both asynchronously. If you paid for it, it's your right to complain. Go after the seller. – Robson Sobral Nov 14 '16 at 17:36
  • Good idea. Thanks for the intel. Permit me one more question...I feel like an idiot asking this...where is that within the Console interface under the dev tools. I googled it and can't find that direction anywhere. – Greg Nov 14 '16 at 18:35
1

If you really are using no channels, you probably can static cache the site without problems. But equally, not clear this will help, as the main cause of delay in EE is data access and composition to then load into templates to generate the HTML you see: if you have no channels then presumably no data access and very little EE caused delay. Having looked at the site I would guess the probable cause is loading up video - for which EE optimisation / caching won't help.

0

Just found at per there documentation, it does:

"The greater the number of tags and variables you use, the more processing cycles the template rendering engine has to perform."

but luckliy there is caching

https://docs.expressionengine.com/latest/optimization/caching.html

0

I used gzip compression per googles suggestion. Thankful that EE makes that simple in the settings. Seemed to have help for approx 1 second of saved time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.