1

I'm trying to upload a .rfa to the file manager in EE2 but it's giving me the error "File not allowed.". I've added the mime type to config/mimes.php which is just application/octet-stream (I checked used chrome dev tools).

The allowed file type is "All" on both the File Upload Preferences and field type, it's under the servers file size limit and other file types such as .jpg and .zip work fine. I also disabled XSS security check. I've tried it on a different server and it's giving me the same problem. Anything else I can investigate?

1

I solved it myself. In the end I had to load the site up locally and step through the php files using a debugger to find out what it was.

Although the file was being uploaded as application/octet-stream it was coming through as application/CDFV2-corrupt in ExpressionEngine. So I added application/CDFV2-corrupt to the list of mime types and it works.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.