2

I've got an ExpressionEngine 3.5.1 website and the comments posted by the public ('Guests' in EE speak, or non-logged in users) are appearing immediately after posting. We want the comments to go through moderation and have set it up appropriately but it's not working.

The way it's set up is in the Admin > Members > Member Groups I've set 'Guests' to:

  • Submit comments = Yes
  • Bypass moderation = No

The comment module is enabled and the form in the template has been done following EE's documentation, e.g.

{exp:comment:form channel="myblog" preview="channel/preview"}

        {if logged_out}
        <div class="row">
            <div class="col-xs-6 col-md-6 form-group">
                <label for="name">Your Name:</label> 
                <input type="text" name="name" value="{name}" size="50" required class="form-control" placeholder="Your name">
            </div>

            <div class="col-xs-6 col-md-6 form-group">
                <label for="email">Email Address:</label>
                <input type="text" name="email" value="{email}" size="50" required class="form-control" placeholder="Your email address">
            </div>
        </div>
        {/if}

        <div class="form-group">
            <label for="comment">Post your comment...</label>
            <textarea name="comment" cols="80" rows="5" required class="form-control" placeholder="Write your comments here">{comment}</textarea>
        </div>

        <label><input type="checkbox" name="save_info" value="yes" {save_info} /> Remember my name &amp; email address</label><br />


        {if captcha}
                <label for="captcha">Please enter the word you see in the image below:</label><br />
                <p>{captcha}<br />
                <input type="text" name="captcha" value="{captcha_word}" maxlength="20" /></p>
        {/if}

        <div class="text-center mt-25">
            <input type="submit" name="submit" value="Post Your Comment" class="btn btn-primary btn-lg btn-red">
        </div>

{/exp:comment:form}

I've logged out of the Admin panel and even tried it in a Chrome Incognito browser window to make sure it's not using any session/cookie data that thinks I'm an Admin.

The comments appear... but we don't want them to go directly on the site without moderation. How can I fix this?

I've updated to EE 3.5.1 today which is the absolute latest version to make sure it's not an EE bug. Same behaviour as my older version.

3

I see that you have your member group preferences set, how about the channel preferences - Moderate comments [yes | no] for the channel in question?

1
  • This is the correct solution. There are a number of settings under Channel Settings > Commenting. In my case "Moderate comments?" was set to No, when changing to Yes, the behaviour works as expected. I find that there are too many settings in EE just to get comments working - they are in about 3 different parts of the Admin panel. But I guess this is to allow flexibility on different channels in respect to users submitting comments and how they are processed. – Andy Jan 26 '17 at 9:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.