I'm trying to install a new module into ExpressionEngine and no matter what I try, I can't get the new module to show up in the control panel under Add-Ons > Modules. I suspect there is some kind of caching or permissions issue, but I've given 777 to all possibly related directories and cleared all the cache I know about. I've run "Run Module Updates" a few times as well.

The reason I think this might be caching is that I've tried to add several other plugins to the system/expressionengine/third_party directory, and these will not show up either. A few days ago (before I found this new plugin that I want), I added one that did show up in the list. I then tried deleting it but it still shows up in the list...

The module I'm trying to add is CE Tweet, and I've followed these installation instructions to a T: http://docs.causingeffect.com/expressionengine/ce-tweet/installation.html

I have also checked that my system meets the module's requirements:http://docs.causingeffect.com/expressionengine/ce-tweet/requirements.html

I am running EE 2.8.1.

In case this has any relevance, my system directory is actually named admin. I've read that this is fine as long as your configs are set up to expect that, but maybe it has something to do with this.

Please help if anyone can point me in the right direction! I'm under a deadline but can't even start

  • Is this local build, or on the server? Look in /admin/expressionengine/config/config.php - is "third_party_path" defined? Is ce-tweet in it's own folder in the modules folder? Commented Feb 1, 2017 at 9:32

2 Answers 2


Try turning on 'report errors' in the CP. It may give you some insight.

Also, sounds whacky, make sure you're site is configured to the correct locale. Often this can arise because the site is using another db or folder setup or someone has moved the third party location on server.


I finally figured this out, thanks to Peter Lewis's comment above. I went on a hunt to figure out what my third_party_path and discovered that it was set to a completely different directory (different than all the documentation I've read and the official instructions for the plugin). For future reference, I could easily see what it was in because of Health Check, which I believe is another add-on. I tried copying my downloaded module file to the directory my third_party_path was configured to and it worked!!! I inherited this site from a different developer, so it was probably something custom they set up.

This was a local build, to answer the question above.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.