4

I cannot search for youtube video anymore. I get the following error

{
 "error": {
  "errors": [
   {
    "domain": "usageLimits",
    "reason": "accessNotConfigured",
    "message": "Project 896194494972 has been scheduled for deletion and cannot be used for API calls. Visit ___ttps://console.developers.google.com/iam-admin/projects?pendingDeletion=true to undelete the project.",
    "extendedHelp": "___ttps://console.developers.google.com/iam-admin/projects?pendingDeletion=true"
   }
  ],
  "code": 403,
  "message": "Project 896194494972 has been scheduled for deletion and cannot be used for API calls. Visit https://console.developers.google.com/iam-admin/projects?pendingDeletion=true to undelete the project."
 }
}

how can I fix it?

thank you monica

  • This isn't really an answer to your question, but some information you may find useful: DevDemon has been acquired by Vector Media Group (makers of CartThrob). Their announcement says that they're going to examine all EE plugins with an eye toward finishing porting them to 3.0. This particular plugin will possibly also be fixed or upgraded at that time.) To get more help with your issue, can you please add which version of EE you're using, and which version of the plugin you're using, to your original question? Also, can you search for ANY videos? That looks like a YT "video deleted" message. – LiAnn Feb 7 '17 at 3:24
4

(I'm with Vector; we're the new owners of DevDemon.)

This error was related to the transfer of DevDemon assets from the old owners over to us. We're now (2017-02-15) released Channel Videos v3.2.1 with a new API key which fixes the issue: http://www.devdemon.com/expressionengine-addons/channel-videos

| improve this answer | |
  • Do you have an ETA of when this will be fixed? Thanks! – jrrdnx Feb 13 '17 at 15:58
  • We hope to release a new version within the next few days. Thanks for your patience! – Matt Feb 13 '17 at 20:48
  • @jrrdnx The updated version has been released: devdemon.com/expressionengine-addons/channel-videos – Matt Feb 15 '17 at 18:12
3

If you don't feel like waiting on DevDemon to make a patch you can create your own youtube API key and replace the key that is in pbf.min.js with your own key. That fixed it for me.

| improve this answer | |
  • Hi, that sounds great, but I cannot find where to change the api key in pbf.min.js Can you help me? – user2273463 Feb 11 '17 at 12:09
  • 1
    Search for this string: AIzaSyCaVU3uYehPlaQQqgIo66N9FCZhRN1kbNg. That's what you'll want to replace. – Matt Feb 13 '17 at 14:49
  • I installed the updated version and now it works. Thank you! – user2273463 Mar 2 '17 at 12:16
0

I updated CV to the latest (3.2.1) on EE 2.11.7. I am getting the following console errors:

GET https://www.googleapis.com/youtube/v3/search?q=bible&maxResults=10&type=video&part=snippet&key=AIzaSyCaVU3uYehPlaQQqgIo66N9FCZhRN1kbNg 403 ()

Replacing the API code to our own still seems to call the AIzaSyCaVU3uYehPlaQQqgIo66N9FCZhRN1kbNg API key. What could be happening?

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.