I installed EE 3.5.4 on a local server (Wamp 3.0.6 - Windows 10), during the installation script execution, the CSS files were not taken into account, then the installation display was summary. The installation worked well.

When I entered in the admin page, the same problem occurred: the CSS files were not taken into account, there was only text. Then I looked at the path of the CSS file and it had admin.php in the path


The httpd.conf

LoadModule rewrite_module modules/mod_rewrite.so
LoadModule vhost_alias_module modules/mod_vhost_alias.so
# Virtual hosts
Include conf/extra/httpd-vhosts.conf

the httpd-vhosts.conf

<VirtualHost *:80>
    ServerName localsite
    DocumentRoot "d:/drive/sites/www/localsite"
    <Directory  "d:/drive/sites/www/localsite/">
        Options +Indexes +Includes +FollowSymLinks +MultiViews
        AllowOverride All
        Require local

Inside the Windows hosts file: localhost
::1 localhost   localsite
::1 localsite

This problem never happened to me before. I managed to solve the problem

In the config.php file:


I added:

$config['theme_folder_url'] = 'http://localsite/themes/';

And now the CSS path is right (no more admin.php):


Really I do not understand this problem, is it possible to remove admin.php in the CSS path without modifying the config.php file?

PS : i tried to install EE2, there was a problem with the images path.

  • 1
    I've never seen this before - it seems that somehow during the installation, admin.php was added to the site URL. This value doesn't have to be changed via config.php - it can also be changed in the URL and path settings in the control panel. But it is fixed now yes? Mar 22 '17 at 20:34
  • Hi Derek, me too I've never seen this before. I tried many times, each time the installation script was without CSS, the admin panel too. Yes the config.php modification has solved the problem. I wrote this post in case an other person encounter the same problem. I will investigate the Wamp setting.
    – Stéphane
    Mar 23 '17 at 0:32
  • It could give an headache for someone who doesn't know how to set config.php and Wamp
    – Stéphane
    Mar 23 '17 at 0:35

I've found a solution:

In the httpd.conf (Windows 10, Wampserver 3.0.6 64 Bit)

I replaced:

DocumentRoot "${INSTALL_DIR}/www" 
<Directory "${INSTALL_DIR}/www/">

to the name of my sites root:

DocumentRoot "D:/drive/sites/www"
<Directory "D:/drive/sites/www/">

I removed:

$config['theme_folder_url'] = 'http://localsite/themes/';

In the config.php file:


And now, no more problems with the CSS path, not need anymore to change this value via config.php. It was a Wamp (3.0.6) , Apache (2.4.23) config setting.

The Answers from those questions helped me to solve this problem:


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.