2

When I try and upload images to my EE site (either from my file manager or from a file field in the channel entry form on the CP), I get a "Error: File Not Found" message. The file gets uploaded to my server, but the database doesn't have an entry for the upload.

Any thoughts on what is going on and/or how to debug the issue?

  • Did you ever figure out the issue? I'm having the same problem. – Christian Parker Nov 2 '17 at 11:01
  • I fixed my issue by removing file upload definitions from my config file. I used the config file to modify upload directories in different environment (local development, staging and production). Now I just manually keep the upload directories by editing the corresponding table in the database. I hope that helps. – Jim Arment Nov 3 '17 at 23:38
  • Thanks Jim, I also use the config file to manage upload preferences after some hours of debugging I realised that the upload path was missing the trailing forward slash “/“ this resolved the problem I was having. – Christian Parker Nov 5 '17 at 9:00
1

Had the same issues here. I'm setting my url and directory paths in a config file but was missing the trailing slash as mentioned above on my path. I should note, my issue was happening on a IIS server.

Didn't Work:

http://www.website.com/images/uploads/blog/
C:\inetpub\wwwroot\images\uploads\blog

Worked: (notice unix style trailing slash on path)

http://www.website.com/images/uploads/blog/
C:\inetpub\wwwroot\images\uploads\blog/
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.