0

0 down vote favorite I'm trying to upgrade from 2.11 to the latest 3.x.

in my user >addons I only installed 3x compatible adds on; however, I keep getting error msgs for the adds that are not there any more than were 2.x compatible I get an error like:

error Unable to load the following extension file... If I try to load the old ones back in I eventually get a 500 error

...any ideas?

  • did you have other addons in your 2.x installation? might be there are still database references for those addons. You'll have to delete those from a few tables manually. @derekjones and the other people over at eecms.slack.com will know exactly where – Jelle Dijkstra Apr 4 '17 at 6:48
1

From the documentation:

Add-ons that you will not be using in v3 must be uninstalled and refactored out of your site before upgrading.

It sounds like you've just removed files, and not actually uninstalled the add-ons via the Add-on Manager in the control panel. If so your site still contains references to those old add-ons.

Rollback to your backup that you made just before beginning the upgrade, follow the instructions above, and you should be okay.

| improve this answer | |
  • Thank Derek! I missed that in the doc, but figured that might be it. I reverted back all my old files, but now I'm getting a 500 error. Do I need to import the backed up sql into the db also? – therooster Apr 4 '17 at 16:37
  • Yes, both the database and the files should be restored to your pre-update backup. – Derek Jones Apr 4 '17 at 16:46
0

If you cannot upgrade your EE2 add-ons to EE3 or there are no equivalents then you're stuck with EE 2.

Which add-ons are incompatible?

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.