1

enter image description here

I'm receiving the above error when attempting to install a new EE3 site. This is the first site we are attempting to stand up on a new WHM server running PHP7. Is there a mechanism to try and get a more detailed error message?

I have confirmed via MySQL Workbench that the settings are correct, but given the non-descript error, I'm somewhat at a loss for where to go next.

This is a brand new server so it's possible a PHP module is missing...

  • Try using 127.0.0.1 instead of localhost. Could be other things, but mostly it's saying the credentials are bad. If you pasted them in, make sure there are no spaces before and after the uname and pwd. – Jim Wyse May 4 '17 at 15:26
  • @JimWyse no dice with 127.0.0.1, as for the creds. I copy and pasted them in the same instance as I did when setting up the connection in MySQL Workbench so it's highly unlikely that is the case. (i.e. paste into the ee3 config switch programs and then paste into workbench so it was the exact same info in the clipboard that was pasted) – Jared May 4 '17 at 16:14
  • I did go ahead and manually type it in after changing it to a text field and it's still offering up the same message. – Jared May 4 '17 at 16:21
  • In your Setup files, go to "System > ee > installer > controllers > wizard.php". In line 88 change the $userdata array's database value to "mysqli" from "mysql" and run the setup again – Mufi - Amici Infotech May 5 '17 at 7:33
1

This ended up being simple. For my instance, the MySQL module wasn't installed for PHP. Once it was added it worked as expected... My issue ended up being the fact that the error was completely non-descript.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.