1

The link is sent to me in an email when I reset my password via front end login form and works as it should when I remove the index.php from the url. I have already created a rule in .htaccess to remove index.php from urls.

Here is my current .htaccess:

<IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /

    # Removes index.php from ExpressionEngine URLs
    RewriteCond %{THE_REQUEST} ^GET.*index\.php [NC]
    RewriteCond %{REQUEST_URI} !/system/.* [NC]
    RewriteRule (.*?)index\.php/*(.*) /$1$2 [R=301,NE,L]

     # Admin Access
    RewriteRule ^(admin)/?$ $1.php [L,NC]

    # Directs all EE web requests through the site index file
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*)$ /index.php?/$1 [L,QSA]
    # RewriteRule ^(.*)$ /index.php/$1 [L]
</IfModule>
| improve this question | | | | |
0

From your admin panel, Go to General configurations settings and set Name of your site's index page to blank or via FTP edit your config.php file inside config folder and add $config['site_index'] = ""

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.