0

I am trying to upload a 19.3mb pdf file using Channel Files. It does not work for me as I receive the message:

"No file was uploaded or file is not allowed by EE.(See EE Mime-type settings)."

XSS filtering is Off.

All PHP settings have been increased but no luck.

max_execution_time   300
max_input_time       600
memory_limit         1024M
upload_max_filesize  50M

Any help is appreciated.

  • Other than its size is there anything special about the PDF? The PDF format allows all sorts of stuff to be contained that EE may be tripping over... javascript, embedded media etc. – AllInOne Jun 2 '17 at 13:43
  • It's a simple annual report - text and images. The exact same file was successfully uploaded to EE2 (Channel Files). This is a new EE3 site contained within a directory folder using the same hosting account that I am working on (before replacing the live site in the root). – ZEDG Jun 2 '17 at 13:56
  • As a troubleshooting step have you tried altering the settings to allow any type of file for this field? – AllInOne Jun 2 '17 at 14:54
  • It is set as 'All File Types'. I have already uploaded over 100 pdf files in multiple entries. Only this file has the issue, so I am assuming it just HAS to do with the file size. – ZEDG Jun 2 '17 at 15:34
  • I believe if it was a file size error you would get a different message. Suggest you try re-saving the file in a different application (Preview vs Acrobat) and try uploading again. You might also try taking a PDF that does upload correctly and increasing it's file size by adding more pages to it to see that can trigger the same failure. I suspect there is an issue with this particular PDF. – AllInOne Jun 2 '17 at 15:57
0

Just to be sure that it isn't something simple, have you checked your Upload Directory settings to verify that the Allowed file types is not set to Images Only?

Also, please post your EE Version.

| improve this answer | |
  • Thanks for the reply. I have uploaded many pdf files to the field in multiple entries - they all tend to be quite small, under 10M. EE 3.5.2 – ZEDG Jun 2 '17 at 12:41
0

I further increased two settings (not sure if that helped), but also found and updated the 'post max size'. Successfully uploaded a 17MB file.

max_execution_time = 600
upload_max_filesize = 200M
post_max_size = 200M
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.