3

I can't upload .eps extension files to any upload directories. I'm on EE 3.4.5. When I try to upload, I see the following message:

enter image description here

I've tried using the 'mime_whitelist_additions' config override, but it's still not working.

$config['mime_whitelist_additions'] = array(
  'application/postscript',
  'application/eps',
  'application/x-eps',
  'image/eps',
  'image/x-eps'
);

Once that didn't work, I tried to use add the mime types to 'mimes.php' located in:

system > ee > EllisLab > ExpressionEngine > Config > mimes.php

I also saw that there's already a mime type declaration for .eps:

'application/postscript', // .ai, .eps, .ps

So I don't know what's happening, any ideas?

3
  • it might be that the actual file is of a different mime type Jun 7, 2017 at 15:39
  • I've checked it quickly and it's showing as application/postscript. Is there a definitive way for me to find out? I've tried a few different .eps files. Jun 7, 2017 at 15:42
  • Just another note - have tried 'application/octet-stream' in the 'mime_whitelist_additions' config override and that does work too, so either adding it to the mimes.php file, or using the override will work. Jun 8, 2017 at 13:58

2 Answers 2

4

A coworker had this same problem earlier this week and added 'application/octet-stream' to the mime types to solve this.

2
  • You're a lifesaver, thanks. I thought 'application/octet-stream' was for .csv files but that's done the trick. Added it to mimes.php and it's working immediately. Jun 8, 2017 at 13:37
  • So did we, I'll pass the good word off to my coworker, glad it's working! Jun 8, 2017 at 13:51
0

Assuming that your upload directory settings are set to allow all file types (and not just images), have you tried using turning off XSS cleaning?

EPS files have many similarities with PDF's so perhaps this thread regarding PDF's will be useful.

1
  • I have XSS Filtering Turned off entirely, and should have mentioned that the directories I'm trying are set to all files. I'm also using the "Focus Lab, LLC Master Config" but have tried adding the 'mime_whitelist_additions' override to the standard config.php file. Jun 8, 2017 at 8:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.