0

I'm building a search form using Solspace's Super Search but I'm getting some strange results on one of the fields.

It's a field that searches cable categories. The available options are:

<label for="cable_category">Category:</label>
<select name="cable_category">
    <option value="">-</option>
    <option value="8.2" {if super_search_cable_category_82}selected="selected"{/if}>8.2</option>
    <option value="7A" {if super_search_cable_category_7A}selected="selected"{/if}>7A</option>
    <option value="7" {if super_search_cable_category_7}selected="selected"{/if}>7</option>
    <option value="6A" {if super_search_cable_category_6A}selected="selected"{/if}>6A</option>
    <option value="6" {if super_search_cable_category_6}selected="selected"{/if}>6</option>
    <option value="5e" {if super_search_cable_category_5e}selected="selected"{/if}>5e</option>
</select>

The form's working perfectly for other fields but if I try to search for '7A' or '6A' it just displays all results. The URL changes but the search doesn't work. If I search for '5e' it works as it should.

I've tried setting the search to use 'exact' searching but that made no difference. I've also tried using lowercase (i.e. 7a) but that made no difference either.

The really strange thing is that if I search for '5e' that works perfectly?

Any ideas to what's going on would be very gratefully received.

Thanks in advance,

Tom

Versions: EE version 2.9.2, Super Search version 2.2.3

0

This is a sad issue with Super Search, but it is likely doing this because of a combination of you having a in your Ignore Keywords list in control panel and the search query containing/starting with a number. :)

| improve this answer | |
  • It was indeed being caused by 'a' being in the ignore keywords list. All sorted now, thanks – Tom Perkins Oct 6 '17 at 5:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.