1

I am new to EE (but familiar with PHP, SQL, etc.) and am trying to run an EE site locally that was originally made by another developer. It is a large, complex site with numerous plug-ins.

EE verson is 2.8.1. My local setup is Windows 7 64-bit and MAMP with PHP 5.5.38 (the same version the site was built for) and MySQL 5.6.34.

I have imported the db, changed the config file to use my own disk paths etc., and installed further requisites with PHP Composer.

Now, when I visit index.php, I get a completely blank page. I have confirmed that index.php runs to completion (by adding a test 'echo' statement at the end), but it produces no output, even with $debug=1, and I see nothing in the Apache and PHP error logs. (I've also noticed that, when I visit the EE control panel, I can log in, but the CSS styles are all missing.)

I suspect I may have missed something in the config file, problem but am unsure what to try next. Any suggestions? Thanks.

  • Seems like your paths are not correct. You need to add right path for theme and template folder. – Mufi - Amici Infotech Jun 22 '17 at 12:36
  • In environment.php: ENV_LIVE_SITE_URL = localhost/millweb ENV_SITE_URL = localhost/millweb ENV_PATH = C:/MAMP/htdocs/millweb ENV_ENVIRONMENT = dev And I also had to add this, to fix errors with extensions not loading: $assign_to_config['third_party_path'] = 'C:/MAMP/htdocs/millweb/third_party'; I believe remaining (CSS) problem is with Theme path. I set it to correct "C:/MAMP/htdocs/millweb/themes/", but still no CSS in control panel: that HTML uses "/themes/filename". It should be "/millweb/themes/filename". How/where can I fix that? – equin0x80 Jun 22 '17 at 13:39
-1

Solved it in the end. The problem was a missing slash / at the end of the "third_party_path" config setting.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.