0

I have a strange problem and I think there is a bug in the platform (v2.9.2 - Build Date: 20141004 ), related to Grid field.

I'm trying to access more fields and one of this fields need to be accessed many times in the template for example:

{grid_name search:field_used_for_search="criteria"} 
  something 
  {grid_name:field1} ........
  {grid_name:field1}........
  {grid_name:field1}......
  {grid_name:field2}.........
  {grid_name:other_field}.........
  {grid_name:field3 status="Active"}
    {grid_name:field3:count}
    ...... 
  {/grid_name:field3}
  {grid_name:field1}
{/grid_name}

I added two new fields in channel fields for this Grid, because I need to add a new feature in website and when I tried to access those new fields I had a big surprise, the page displayed something like:

{grid_name search:field_used_for_search="criteria"} 
  {grid_name:field3 status="Active"}

  {/grid_name:field3}
{/grid_name}

Let's presume that I want to to show a field (doesn't matter if is one of those added recently or olds) somewhere inside grid_name tag. I thought maybe is something with my new fields and I tried to access others (old ones) and is the same behavior. So I deleted some of the old recurrence from my template and I access other one and surprise, works.

The way that I access those fields is right. So if I delete for example two recurrence of {grid_name:field2} I can access those two fields added recently, but if I keep the old ones and I try to display all of them I get the previous error.

Do you have some suggestions ?

PS: The template is very large (320 full lines, without white lines), can be a problem related to this ?

Thanks, Bobo

0

Possibly fixed in next EE version 2.9.3?:

Fixed a bug (#20704) where Grid tags may not parse correctly if multiple Grid tag pairs are present and one tag pair contains no variables.

https://docs.expressionengine.com/v2/about/changelog.html#version-2-9-3

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.