0

We have a Contact Form for a client that is somehow allowing users to submit it with blank fields that are set to be required. Submissions appear to be from valid sources...aka not spam. When we attempt to test it on multiple devices, operating systems, and browsers, ALL validation works as expected.

ExpressionEngine Version: 2.9.2 Freeform Version: 4.2.2

Here is an example of the form showing errors for blank fields.

Image showing validation working

Here is the backend of Freeform showing a couple of submissions that have gotten through with blank fields.

Freeform submissions with blank fields

If we could recreate the situation we believe we could fix it. Unfortunately, everything we tried, the system works as expected.

Has anyone had a similar experience? If yes, did you find a solution solution?

  • Is it JavaScript dependant or validated on the backend? – stuartmcd69 Aug 16 '17 at 8:28
  • did you specify the required fields in the "required=" parameter? Is this a composer form or built out in the template? – Jim Wyse Aug 16 '17 at 12:15
  • Form is built out in the template. "required=" parameter is set. We turned off JS in several browsers and still couldn't replicate the issue, so not dependent. Should be validated server side. – Bart Paden Aug 17 '17 at 13:38
0

Sorry, don't have enough rep points to comment, but I also just had this issue. It's a multi-page Composer Form and has been working for over a year. Yesterday a submission came through where most of the required fields were blank. Did you figure out what was going on by any chance?

| improve this answer | |
  • No solution at this point. – Bart Paden Sep 13 '17 at 13:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.