0

I have an instance of Low Search 4.4.3 running on an MSM enabled instance of EE 2.11.8.

It runs many Collections happily across 3 sites.

But with a new site recently added, when I go to Save any newly configured Collection, it returns a database error:

Error Number: 1048 Column 'modifier' cannot be null INSERT INTO exp_low_search_collections (site_id, channel_id, collection_name, collection_label, language, modifier, excerpt, settings, edit_date) VALUES (10, '84', 'about', 'About', 'en', NULL, '523', '{\"0\":\"3\",\"523\":\"2\",\"524\":\"2\",\"536\":\"3\"}', 1503055683) Filename: third_party/low_search/model.low_search.php Line Number: 209

The relevant line in model.low_search.php is:

ee()->db->insert($this->_table, $data);

Any suggestions for fixing?

  • My suspicion is that this is related to updating to 2.11.8 some months ago. – Jonathan Schofield Aug 18 '17 at 12:47
  • As a workaround, it seems I can create Collections via MySQL Insert and then edit from within the CP. – Jonathan Schofield Aug 18 '17 at 13:01
  • …Though saving an inserted Collection in the CP resets the modifier to 0.0. The modifier sticks if subsequently changed in the DB, at least until the next Save. – Jonathan Schofield Aug 18 '17 at 13:11
0

The error says it's trying to fill in a NULL value for the Modifier, but that isn't allowed. Looking at the code for version 4.4.3, there's no way a NULL value could be added. Even when I remove the whole modifier field before submitting the form, I'm not getting that error.

Maybe update to the latest legacy version (v4.4.5), make sure the modifier column in the exp_low_search_collections table has a default value of 1.0, and try again. Oh, and maybe try with extensions disabled, too.

If the problem persists, open a thread over at GetSat, which is better suited than EESE for going back and forth with questions.

| improve this answer | |
  • Many thanks, Low. I'll run the update next week (I have things working via MySQL insert for now). Hoping the client upgrades to EE3 soon :) – Jonathan Schofield Aug 18 '17 at 15:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.