0

I am using FreeForm 4.1.3 and ExpressionEngine 2.7.3. I have a form that was working for a while and I think I am running into an issue now. I did have to recently go into EE settings and update my file upload location of my host. I updated the Server Path to Upload Directory under CP Home -> File Manager -> File Upload Preferences -> Edit File Upload Preferences. I guess the host of my client updated their hosting somewhere along the lines and now when I try to upload certain documents it knocks out my site.... In chrome I get...

This page isn’t working

www.xxxxxxxxx.com didn’t send any data. ERR_EMPTY_RESPONSE

I am not sure what is going on.... I can back my page up and submit again with a txt file and it submits....just not a docx....I have file uploads set to all file types.

  • I am noticing I can do any file through file manager upload file but not docx. I have past docx's in here so I know they used to work. Any ideas where I can do this? in my mimes.php file i have docx there and under security and session I have Apply XSS Filter to uploaded files set to Yes. – whreed Oct 9 '17 at 2:40
  • If you're confident that users won't upload malicious files turn off xss filtering. – stuartmcd69 Oct 9 '17 at 3:50
  • When i turn off xss filtering I still have the issue of uploading docx files. I get a weird broken image icon when I use the built in file manager and try to upload a docx. – whreed Oct 9 '17 at 16:12
0

GoDaddy moved me to a new server that has modsecurity on for docx, since it's a shared environment I cannot disable it to allow docx uploads....hope this helps someone else.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.