1

I've got a secondary site using WYVERN. Everything works fine, and when I insert an image, WYVERN puts

/files/imagePath/image.gif

In the code. So the code is correct, but since I am viewing the EE control panel from the primary site's URL, the image doesn't appear within WYVERN.

Is there some setting I can change in Assets or elsewhere that will prepend secondary-domain.com within WYVERN so the image appears?

[EDIT] Adding to the complexity - this site needs to run over SSL or non-SSL (allowing for visitors in China and other unfree places to access). So code output on the website needs to be relative, i.e., /path/img.gif

not

http://domain.com/path/img.gif
  • Did you try to prepend {site_url}?. So your full path in WYVERN would be {site_url}files/imagePath/image.gif. – Mufi - Amici Infotech Jan 25 '18 at 12:29
  • If I add that in file manager setting, it gets output literally in the path {site_url}/files/imagePath/image.gif. Is there a place in WYVERN config to add it? – 4midori Jan 25 '18 at 16:44
1

Here's a trick:

This allows the CMS to serve files over SSL or non-SSL, depending on whatever protocol is in use.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.