1

I have an MSM site setup but need to change the domain name. I have the new domain name setup and moved the site files to the new domain directory.

I also updated the URLs in the control panel & in the admin.php & index.php files but it does not work. When I visit the new URL, I get the following message: Your system folder path does not appear to be set correctly. Please open the following file and correct this: index.php

But the path is correct. What am I missing?

Thanks for any help.

EDIT: Actually, the path was incorrect. I fixed it and now get the Site Error: Unable to Load Site Preferences; No Preferences Found message.

  • Anyone? No one has ever had to change the domain for an MSM site? – mediapimp Feb 11 '18 at 17:13
0

To change the URL in MSM site you need to change in below variables in index.php.

$assign_to_config['site_name']  = 'domain2_short_name';
$assign_to_config['cp_url'] = 'http://domain2.com/admin.php';
$assign_to_config['site_url'] = 'http://domain2.com';

If you need to change domain name then you should change $assign_to_config['site_url'] = 'http://new_domain2.com' and $assign_to_config['cp_url'] = 'http://new_domain2.com/admin.php' according to your new Domain name.

|improve this answer|||||
  • Yes, I have done all of that. – mediapimp Feb 12 '18 at 13:39
  • So, working fine? – Harsh Barach Feb 12 '18 at 13:42
  • No. It does not work. – mediapimp Feb 12 '18 at 13:46
  • Make sure your main website have all the templates of new site. And new site has only js,css etc folders not ADMIN. – Harsh Barach Feb 12 '18 at 13:48
  • It does. All I did was move the original domain's site files to the new location on the server for the new domain. Then I changed the site url in the control panel and updated the variables in index.php & admin.php. That should be all there is to do but it still does not work. – mediapimp Feb 12 '18 at 13:54
0

Figured it out. Unbeknownst to me, the host was requiring a database user password update. Not sure why it only effected the new site since all other sites were able to communicate with the database.

Once I updated the password, everything worked fine.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.