I am using Expresso Store https://www.exp-resso.com for setting up an ecommerce-site. The problem that I run into, is when I try to install a custom gateway. The Expresso Store support claim that my error have something to do with the EE setting and for that reason they can’t help me. I have been trying to find a solution for the last couple of months without luck. So I hope that someone can guide me in the right direction.

To install a custom gateway via expresso store, there are two things that need to be done:

  1. Installing and activating “Store Check” Store Check in order to use Omnipay based gateways.
  2. Installing desired Omnipay gateways provider from: Omnipay Library (Quickpay in my case)
    • I am successful in installing and activating Store Check plugin.
    • I am also partly successful in installing Omnipay-Quickpay

But, when I in the back-end try to activate the newly created “Quickpay gateway” by entering “Settings > Payment Methods > Quickpay” I run into a number of errors. I have attached a couple of screen shots as illustration of this.

Store Check setup - IMG Backend setup - IMG Error I get:

Exception Caught

Missing setting options in default setting array
user/addons/store/src/helpers.php:209

Stack Trace: hide details
#0 user/addons/store/views/settings/payment_edit.php(32): store_setting_input('payment_methods', Array, false)
#1 ee/EllisLab/ExpressionEngine/Legacy/Facade.php(132): include('...')
#2 ee/legacy/core/Loader.php(867): EllisLab\ExpressionEngine\Legacy\Facade->runFileInFacadeScope('...', Array, false)
#3 ee/legacy/core/Loader.php(460): EE_Loader->_ci_load(Array)
#4 user/addons/store/src/Cp/SettingsController.php(42): EE_Loader->view('settings/paymen...', Array, true)
#5 user/addons/store/src/Cp/SettingsController.php(498): Store\Cp\SettingsController->render('settings/paymen...', Array, 'payment', 'Quickpay')
#6 user/addons/store/src/Cp.php(69): Store\Cp\SettingsController->payment_edit()
#7 user/addons/store/src/Cp.php(55): Store\Cp->route(Object(Store\Cp\SettingsController), 'payment_edit')
#8 [internal function]: Store\Cp->index()
#9 ee/EllisLab/ExpressionEngine/Controller/Addons/Addons.php(1660): call_user_func_array(Array, Array)
#10 ee/EllisLab/ExpressionEngine/Controller/Addons/Addons.php(920): EllisLab\ExpressionEngine\Controller\Addons\Addons->getModuleSettings('store', 'index', Array)
#11 [internal function]: EllisLab\ExpressionEngine\Controller\Addons\Addons->settings('store')
#12 ee/EllisLab/ExpressionEngine/Core/Core.php(189): call_user_func_array(Array, Array)
#13 ee/EllisLab/ExpressionEngine/Core/Core.php(94): EllisLab\ExpressionEngine\Core\Core->runController(Array)
#14 ee/EllisLab/ExpressionEngine/Boot/boot.php(151): EllisLab\ExpressionEngine\Core\Core->run(Object(EllisLab\ExpressionEngine\Core\Request))
#15 admin.php(143): require_once('...')
#15 admin.php(143): require_once('...')

Any help will be truly appreciated, as I have run out of ideas where to look for the answer.

Thanks in advance

  • Hi Nermin. It is unlikely that the error is in either EE3 / Expresso or Omnipay - as both are extensively used and likely that others would have seen these errors if they resided in those bits of code. Which suggests as a first stop you should perhaps contact the author of the Omnipay payment gateway you are using - via github.com/NobrainerWeb/omnipay-quickpay HTH – jcogs.eecms Mar 19 at 14:41

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.