2

This is the error I am getting when trying to install Gmaps by Reinos on EE4.

I'm getting a similar error when trying to install the Gmaps Data Plugin on EE4 as well.

enter image description here

3

You need to change a little in code at line 230 in upd.gmaps of your plugin directory.

'constraint' => '255' to 'constraint' => '191'

This need to change from 255 to 191 because there is INNODB utf8mb4.

| improve this answer | |
  • Thanks! It seems the code change was actually in settings.php for EE4 at line 167. I can now install Gmaps. I am however having a similar issue when installing the Gmaps Data plugin. Any thoughts on that? (See above screenshot I've added to my original post) Thanks for your help. – Matthew McMullen Feb 15 '18 at 19:46
  • Yeah, same thing you need to do in Gmaps Data also. You need to change "constraint" of "lat", "lng", "city", "street_name", "country", "country_code", "search_location" from "200" to "191" in the "settings.php" which was located in the directory of Gamps Data plugin. – Harsh Barach Feb 16 '18 at 2:34
  • great! works for me too – Mufi - Amici Infotech Apr 4 '18 at 15:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.