0

Instead of a normal blue link, LIVE LOOK renders the link like this:
[url="http://www.geomagic.com" target="_blank"]Geomagic[/url]

I am using EE 4.1.3.

How can I prevent the live look preview from rendering the URL links within an article? I would like the links to display as normal "a href" links. I have WYGWAM installed and the {body} field is set to use the WYGWAM add-on. This display issue above also happens on non-WYGWAM fields in live look, too. I would like the links to just render as normal links.

Are there settings or defaults for live look?

Can we update the default CSS/JS live look uses to alter the URLs? I have used a method similar to this for "printer friendly" pages.

0

I found a solution to my own question.

After figuring out that I needed to identify the WYGWAM field as an XHTML-formatted field, I used a simple add-on -- Typography-ee.

https://buzzingpixel.com/software/typographee

This worked:

{exp:typographee:parse text_format="xhtml"}
   {body}
{/exp:typographee:parse}

I use this just for my preview template.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.