I have a site running EE 2.8.1 with Expresso Store 2.3.1. The recent TLS 1.2 PayPal upgrade has caused PayPal Express payments to fail - giving the error - Sorry, there was an unexpected error communicating with the payment gateway.

Is this being caused by the Store code? I need to determine if the issue is software or server related. Any help will be much appreciated.

The majority of the time, this is a server issue. Your host will need to upgrade your server to support later versions of PHP/cURL/etc that allow TLS 1.2.

In general I'd also recommend upgrading Expresso Store to the latest version for EE2 but it shouldn't technically be necessary for this issue to be fixed.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.