0

I'm trying to get channel images to show within a ee relationship. All the title and links show correctly, but the images are not showing at all.

Running EE 3.5.7 and channel images 6.0.3

I'm using the following code:

<aside class="widget latest-post-widget">
<h4>Editors Picks</h4>
<ul>
{exp:channel:entries channel="cria_picks" limit="3"}
{cria_editors_picks}
<li class="media">
<div class="media-left">
<a href="{cria_editors_picks:url_title_path='criaviews/article'}" class="popular-img">
{exp:channel_images:images entry_id="{cria_editors_picks:entry_id}"}
<img src="{image:url:medium}" style="width: 103px; height:76px;" alt="">
{/exp:channel_images:images}
</a>
</div>
<div class="latest-post-content">
<h2><a href="{cria_editors_picks:url_title_path='criaviews/article/'}">
{cria_editors_picks:title}
</a></h2>
<p><time datetime="{cria_editors_picks:entry_date format="%Y-%m-%dT%H:%i"}" pubdate class="updated">{date_heading}{cria_editors_picks:entry_date format="%d %F %Y"}{/date_heading}</time></p>
</div>
</li>
{/cria_editors_picks}
{/exp:channel:entries}
</ul>
</aside>

Not sure what I'm missing. I'm using this code as an embed.

0

Did you check that {cria_editors_picks:entry_id} is a valid ID? You can also try {cria_editors_picks} YOUR CODE {embed"YOUR-FILE" entry_id="{cria_editors_picks:entry_id}"} MORE CODE {/cria_editors_picks}

Then in YOUR-FILE

JUST TO TEST -> THE ID IS : {embed:entry_id} <br>
{exp:channel_images:images entry_id="{embed:entry_id}"}
    <img src="{image:url:medium}" style="width: 103px; height:76px;" alt="">
{/exp:channel_images:images}
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.