0

I am new to ExpressEngine. One of my clients has a website built in EE by another developer. We have just moved the site to a new server, and now we are getting the following errors, if anyone can help that will be great.

Current version is ExpressionEngine 2.5.3

A PHP Error was encountered Severity: 8192 Message: Non-static method Wygwam_helper::replace_page_tags() should not be called statically, assuming $this from incompatible context Filename: wygwam/ft.wygwam.php Line Number: 562

A PHP Error was encountered Severity: 8192 Message: Non-static method Wygwam_helper::replace_page_tags() should not be called statically, assuming $this from incompatible context Filename: wygwam/ft.wygwam.php Line Number: 562

A PHP Error was encountered Severity: 8192 Message: Non-static method Wygwam_helper::replace_page_tags() should not be called statically, assuming $this from incompatible context Filename: wygwam/ft.wygwam.php Line Number: 562

A PHP Error was encountered Severity: 8192 Message: Non-static method Wygwam_helper::replace_page_tags() should not be called statically, assuming $this from incompatible context Filename: wygwam/ft.wygwam.php Line Number: 562

A PHP Error was encountered Severity: 8192 Message: Non-static method Wygwam_helper::replace_page_tags() should not be called statically, assuming $this from incompatible context Filename: wygwam/ft.wygwam.php Line Number: 562

A PHP Error was encountered Severity: 8192 Message: Non-static method Wygwam_helper::replace_page_tags() should not be called statically, assuming $this from incompatible context Filename: wygwam/ft.wygwam.php Line Number: 562

A PHP Error was encountered Severity: 8192 Message: Non-static method Trunchtml::usage() should not be called statically, assuming $this from incompatible context Filename: trunchtml/pi.trunchtml.php Line Number: 37

A PHP Error was encountered Severity: Warning Message: Cannot modify header information - headers already sent by (output started at /home/affinityassetfin/public_html/system/codeigniter/system/core/Exceptions.php:170) Filename: core/Common.php Line Number: 409

Many thanks Shuka

  • What version of wygwam do you have installed? – AllInOne Nov 15 '18 at 23:06
1

This is probably being caused by the new server running a newer version of php: I would start by checking what version the old and new server have.

If they are different, you can either try to revert the new server back to the version on the original server, or update the EE installation to a newer version.

If you go for updating EE, look in the EE2 version changelog for the version you need to update to for compatibility.

Big milestones:

  • php 5.2.4 - EE 2.6.0
  • php 5.3.0 - EE 2.10.3
  • php 7.0 - EE 2.11.0
  • php 7.1 - EE 2.11.9 (the final version)

As you update through EE2 versions you probably will also need to update some of the installed add-ons.

HTH

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.