0

I'm trying to install EE 5.1.3 on my server but keep getting error:

Exception Caught

No such property: 'db' on EllisLab\ExpressionEngine\Legacy\Facade

ee/EllisLab/ExpressionEngine/Legacy/Facade.php:120

Stack Trace: Please include when reporting this error

#0 ee/EllisLab/ExpressionEngine/Legacy/Facade.php(30): EllisLab\ExpressionEngine\Legacy\Facade->get('db')
#1 ee/installer/controllers/wizard.php(853): EllisLab\ExpressionEngine\Legacy\Facade->__get('db')
#2 ee/installer/controllers/wizard.php(272): Wizard->do_install()
#3 [internal function]: Wizard->_remap('do_install', Array)
#4 ee/EllisLab/ExpressionEngine/Core/Core.php(241): call_user_func_array(Array, Array)
#5 ee/EllisLab/ExpressionEngine/Core/Core.php(110): EllisLab\ExpressionEngine\Core\Core->runController(Array)
#6 ee/EllisLab/ExpressionEngine/Boot/boot.php(151): EllisLab\ExpressionEngine\Core\Core->run(Object(EllisLab\ExpressionEngine\Core\Request))
#7 admin.php(153): require_once('...')
#7 admin.php(153): require_once('...')

I have doubled checked that the DB is, in fact, up and running and connected to it using all same credentials in entered on the admin.php install wizard page.

Any help or direction in getting this resolved would be greatly appreciated.

0

are you sure the paths and mysqli settings you used are correct?

1
  • I double checked the mysqli settings by connecting to the db from a third-party client. The install wizard doesn't ask for any paths like the old versions used to. – michaelespinosa Jan 30 '19 at 19:21
0

It turns out my host changed from using "localhost" for accessing the db and had to use a different host. Thanks!

0

Check $config['database'] array in config.php file. If your localhost is running on a different port, you will have to add the port in the hostname in the config.php file like localhost:9090

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.