0

I've got an EE5 site which was upgraded 3 months ago from EE2 and is now having trouble with new images being added.

I turned on debugging and am seeing this issue:

 CE Image debug: Source image is not readable or does not exist: '/uploads/general/Biden%20Holiday%20Card/biden-card-smaller.JPG'.

I've changed the upload folder permissions to 755 and then 777 and still no change with new image uploads.

FWIW the relevant template code is:

    {exp:ce_img:bulk add_dims="no" attributes="class='img-responsive'"}
        {blog_copy}
    {/exp:ce_img:bulk}
  • CE-Image works with EE5 but has not been updated since EE3, and so quite possibly there are issues relating to changes between EE3 and EE4. But more likely you have got a configuration issue with your file directories - if you go to the File directories within EE CP are the thumbnails in that directory showing up OK? – JCOGS Design Apr 15 '19 at 19:11
  • The thumbnails are not showing up correctly - have checked {base_url} and {base_path} and they are both set correctly. Locally and live and yet both are not working here. – CreateSean Apr 15 '19 at 23:07
  • If you are not seeing thumbnails in the Files part of EE, then your issue almost certainly is not to do with CE-Image. I would check first that the settings for each upload directory are not being overwritten (either by settings for the file directory in the Control Panel - where you can override use of {base_path/url} and then in the site's config for overrides to upload directories, or base_url/path settings. – JCOGS Design Apr 16 '19 at 8:24
0

Make sure you are setting your config variables correctly in your index.php or config.php file for CE Image. Here is an example I just pulled from a production EE4 environment (and an MSM site to boot, too, so from the index.php of the MSM site):

$assign_to_config['ce_image_document_root'] = pathinfo(__FILE__, PATHINFO_DIRNAME);
$assign_to_config['ce_image_cache_dir'] = '/ce_images/';
$assign_to_config['ce_image_remote_dir'] = '/ce_images/remote';
| improve this answer | |
  • I already had this in my config file. – CreateSean Apr 16 '19 at 13:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.