0

This is related to another question I asked earlier but the problem is not caused by what I thought.

I did a fresh install of EE on a different server and I'm getting the same js error of Uncaught TypeError: EE.grid is not a function.

I've been pulling my hair out all day trying to debug this, and since it's on a fresh install of EE I'm really, seriously thrown off.

This is happening on any admin Control Panel form that uses file grids. So any type of channel entry that uses images, or evencategories as they have an image uploader, is completely broken and unusable.

When I check the error in the Network tab of the chrome dev tools, this is in the Headers section:

Request URL: http://example.com/admin.php?S=0&D=cp&C=javascript&M=combo_load&plugin=ui.touch.punch,ee_table_reorder&file=cp/global_end,cp/grid,cp/files/picker,fields/file/cp,fields/file/file_field_drag_and_drop,fields/file/concurrency_queue,fields/file/file_upload_progress_table,fields/file/drag_and_drop_upload,fields/grid/file_grid,cp/date_picker&v=1556219934
Request Method: GET
Status Code: 406 Not Acceptable

All I've done with this new project is install EE, let it set up the example project (because it's easier to work off of), add an htaccess file according to the EE docs, and get my editor set up with ftp to the server. I have not touched or installed any modules.

As far as I can tell this has something to do with the combo loader(?????) But if so, why? Would would a brand new install on a brand new server START with errors that make the whole CMS unusable?

Really at a complete loss with this and if I can't get it figured out I'm going to have to abandon this CMS completely, which would really suck because I've invested a lot of time into learning its template system and really, really like working with it.

Any help at all would be immensely appreciated.

[EDIT] Some further strange behavior is that when I post an entry using the example site's blog setup, which contains a video, audio, and image field, it will save those items to the entry weather or not there's anything in them.

enter image description here

HIT SAVE

enter image description here

HIT SAVE AGAIN (without changing anything)

enter image description here

What on earth could possibly be going on here? Again, this is a brand new install of EE 5.2.2

1

Your best bet is to open a support ticket with HostGator and asking them to 'whitelist' those mod_sec rules that are causing the problem. As EE5 isn't as common as say WordPress, most hosting providers therefore don't have the relevant rules whitelisted as they don't have clients that have run into the issue (yet).

If you ask them nicely they might be able to do this for your server/all domains you want to use EE5 with.

| improve this answer | |
  • Thank you! I was able to contact their support and get that whitelisted. They happened to mention that it should be fixed for future EE users on HostGator as well, so this might've saved a headache for future EE devs using HostGator (which is one of the top-rated servers for EE on several review sites). – Shayne Apr 29 '19 at 17:26
  • Good news that your problem is solved! – Stéphane Apr 30 '19 at 2:32
1

It seems to be an Apache server module.

The 406 status code is when a mod_security rule is enabled on an Apache server. So, disable it could resolve this problem.

| improve this answer | |
  • Stéphane: Oh, ok. Well that's actually a relief. So I just need to change the mod_security rules on my server. I've been looking up how to do this and it looks like some hosts make it easy and others don't. HostGator, apparently, is one of the ones that don't. I've tried this fix (tipsandtricks-hq.com/…) using the .htaccess file but to no avail. And HostGator doesn't seem to have any options in the cPannel for changing mod_security and the only thing I can do with Apache is add handlers. Any ideas? – Shayne Apr 26 '19 at 18:22
  • Perhaps it could work to swap the GET method by the POST one in the Jquery script from the EE control panel source code..... – Stéphane Apr 26 '19 at 18:41
  • REQUEST method too – Stéphane Apr 27 '19 at 0:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.