0

I've been struggling with this for a week or two and I'm completely stuck. I've also posted the question here without success: https://expressionengine.com/forums/topic/252326/error-when-finally-updating-to-5.2.2-from-3.x

Here's my error after what appeared to be a successful EE3 > EE5 upgrade. It seems to only happen on my Home/index page, but all other pages work perfectly fine. Does anyone recognize this error?

Exception Caught

SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘m.url’ in ‘field list’: SELECT t.entry_id, t.channel_id, t.forum_topic_id, t.author_id, t.ip_address, t.title, t.url_title, t.status, t.view_count_one, t.view_count_two, t.view_count_three, t.view_count_four, t.allow_comments, t.comment_expiration_date, t.sticky, t.entry_date, t.year, t.month, t.day, t.edit_date, t.expiration_date, t.recent_comment_date, t.comment_total, t.site_id as entry_site_id, w.channel_title, w.channel_name, w.channel_url, w.comment_url, w.comment_moderate, w.channel_html_formatting, w.channel_allow_img_urls, w.channel_auto_link_urls, w.comment_system_enabled, m.username, m.email, m.url, m.screen_name, m.location, m.occupation, m.interests, m.aol_im, m.yahoo_im, m.msn_im, m.icq, m.signature, m.sig_img_filename, m.sig_img_width, m.sig_img_height, m.avatar_filename, m.avatar_width, m.avatar_height, m.photo_filename, m.photo_width, m.photo_height, m.group_id, m.member_id, m.bday_d, m.bday_m, m.bday_y, m.bio, md., wd. FROM exp_channel_titles AS t LEFT JOIN exp_channels AS w ON t.channel_id = w.channel_id LEFT JOIN exp_channel_data AS wd ON t.entry_id = wd.entry_id LEFT JOIN exp_members AS m ON m.member_id = t.author_id LEFT JOIN exp_member_data AS md ON md.member_id = m.member_id WHERE t.entry_id IN (3737) ORDER BY t.sticky desc, t.entry_date desc, t.entry_id desc

ee/legacy/database/drivers/mysqli/mysqli_connection.php:117

Blockquote

Stack Trace: Please include when reporting this error

0 ee/legacy/database/drivers/mysqli/mysqli_driver.php(112): CI_DB_mysqli_connection->query(‘SELECT t.entry…’)
1 ee/legacy/database/DB_driver.php(270): CI_DB_mysqli_driver->_execute(‘SELECT t.entry…’)
2 ee/legacy/database/DB_driver.php(180): CI_DB_driver->simple_query(‘SELECT t.entry…’)
3 ee/EllisLab/Addons/channel/mod.channel.php(248): CI_DB_driver->query(‘SELECT t.entry…’)
4 ee/legacy/libraries/Template.php(1847): Channel->entries()
5 ee/legacy/libraries/Template.php(1482): EE_Template->process_tags()
6 ee/legacy/libraries/Template.php(578): EE_Template->tags()
7 ee/legacy/libraries/Template.php(234): EE_Template->parse(‘{!– ra:0000000…’, false, 1, false)
8 ee/legacy/libraries/Template.php(165): EE_Template->fetch_and_parse(”, ”, false)
9 ee/legacy/libraries/Core.php(661): EE_Template->run_template_engine(”, ”)
10 ee/legacy/controllers/ee.php(63): EE_Core->generate_page()
11 [internal function]: EE->index()
12 ee/EllisLab/ExpressionEngine/Core/Core.php(241): call_user_func_array(Array, Array)
13 ee/EllisLab/ExpressionEngine/Core/Core.php(110): EllisLab\ExpressionEngine\Core\Core->runController(Array)
14 ee/EllisLab/ExpressionEngine/Boot/boot.php(151): EllisLab\ExpressionEngine\Core\Core->run(Object(EllisLab\ExpressionEngine\Core\Request))
15 public_html/index.php(173): require_once(‘…’)
15 public_html/index.php(173): require_once(‘…’)
0

The EE 4.0.0 upgrade script did some wackiness with some of the member fields and moved them from columns to to their own data table, and URL is one of them. However, if it didn't exist as a column before, it just does nothing I believe. Is this a system that was originally on EE1? I have a suspicion that the EE1 -> EE2 upgrade doesn't create/move over some member columns/fields that a raw install of EE2.X creates. Just a theory.

It's a buggy step in the upgrade. Also, you might have an add-on or something looking for that column when it doesn't exists. Honestly, I would just create that column in the exp_members table and it'll probably do the trick. I looked up a pre-EE4 system and got the structure for that column:

`url` varchar(150) COLLATE utf8_unicode_ci DEFAULT NULL

So just fire up your favorite MySQL tool and create that column.

Also, I read your question on the forum. I absolutely recommend going one major version at a time (if you do any future EE upgrades), and upgrading add-ons in-between. For major EE upgrades I even have a set of the update scripts modified to log every function fire to watch for where things fail or stall. I've upgraded some behemoth EE systems in the last few years.

4
  • thanks so much! i'm really at a standstill here and this gives me something to work off of. Yes, this was originally an EE1 install that I've updated over time. I'll try this out.
    – Bardo_J
    May 22 '19 at 12:15
  • One weird tidbit: this error only gets thrown on my Home/index page. That Home page isn't using any add-ons or unusual expression engine code...it's just 4 different channel entries loops with member_data disabled. Odd
    – Bardo_J
    May 22 '19 at 12:21
  • I'm in my database and the url column DOES exist in the table exp_members
    – Bardo_J
    May 22 '19 at 12:25
  • I tried the upgrade process from EE3 > EE4 and am getting the same error.
    – Bardo_J
    May 22 '19 at 13:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.