0

I am upgrading from EE2 to EE3. I have the latest version (2.11.9) and have followed the steps to download EE3, copy the config.php and database.php files, disable and remove plugins, and then copy /system, /themes/, admin.php, and index.php over.

However, after that, when I visit /admin.php to run the installer, I can't get it to run. It just shows me an error:

SQLSTATE[42S02]: Base table or view not found: 1146 Table 'xyz.exp_plugins' doesn't exist: SELECT plugin_package FROM (exp_plugins) ee/legacy/database/drivers/mysqli/mysqli_connection.php:122

Can anyone tell me how to get the installer to run? I also tried visiting /system and /system/ee/installer in the browser.

I got the upgrade instructions here:

https://docs.expressionengine.com/v3/installation/upgrade_from_2.x.html

I got EE3 from here (master-v3 branch):

https://github.com/ExpressionEngine/ExpressionEngine/tree/master-v3

1

Seems to be an add-on problem. So try to uninstall, or update it this add-on before to to the update. Check if this addon is EE3 compatible or not, if it still exists, and if it is useful or not.

Could have a look here: EE2 upgrade to EE3, how to upgrade addons?

Will add-ons for EE2 work in EE3?

| improve this answer | |
  • Before to update, delete add-on backup your database ! – Stéphane May 21 '19 at 20:22
  • 1
    Thanks! I had actually already removed all third party add-ons. See my answer below for the culprit. – Micah May 23 '19 at 2:58
1

Try to visit the installer directly; it sounds like your admin.php file is trying to load the Control Panel system and not the installer. The plugins table is created in the EE 3.0.0 update script, which clearly hasn't run yet.

Something might also be wacky in your config.php, making EE think it is already upgraded. Make sure your config file version number matches 2.11.9.

Try to visit this URL (replace the proper terms for your domain/environment):

www.mydomain.com/system/installer/index.php
| improve this answer | |
  • Thanks for your answer. Turns out I downloaded the v3 master branch, whereas I was supposed to download the 3.5.17 release tag. When I did that, it worked as described in the documentation. Thanks again. – Micah May 23 '19 at 2:53
1

When upgrading to v3, you have to download the specific release tag instead of just downloading the v3 master branch. This is the link:

https://github.com/ExpressionEngine/ExpressionEngine/releases/tag/3.5.17

Then, the installer folder will be there and automatically run when visiting /admin.php.

Be sure to download the 1st file on that page named after the release and NOT the source code zip. The source is not packaged as an app to be deployed to a production website.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.