0

I'm trying to use Moblog on a site and I've run into an issue.

A little background info:

  • EE 5.2.6
  • Moblog 3.2.0
  • New install
  • 1 channel with two fields (Post - textarea, Post Media - file upload field)

When I use the "check now" option in the add-on control panel, I get the following error:

Exception Caught
SQLSTATE[42S22]: Column not found: 1054 Unknown column 'field_group' in 'field list':
SELECT `site_id`, `channel_title`, `channel_url`, `rss_url`, `comment_url`, `deft_comments`, `cat_group`, `field_group`, `channel_notify`, `channel_notify_emails` FROM (`exp_channels`) WHERE `channel_id` = '1'

ee/legacy/database/drivers/mysqli/mysqli_connection.php:117
Stack Trace: Please include when reporting this error

    #0 ee/legacy/database/drivers/mysqli/mysqli_driver.php(112): CI_DB_mysqli_connection->query('SELECT `site_id...')
    #1 ee/legacy/database/DB_driver.php(270): CI_DB_mysqli_driver->_execute('SELECT `site_id...')
    #2 ee/legacy/database/DB_driver.php(180): CI_DB_driver->simple_query('SELECT `site_id...')
    #3 ee/legacy/database/DB_active_rec.php(1206): CI_DB_driver->query('SELECT `site_id...')
    #4 ee/EllisLab/Addons/moblog/mod.moblog.php(936): CI_DB_active_record->get_where('channels', Array)
    #5 ee/EllisLab/Addons/moblog/mod.moblog.php(875): Moblog->post_entry()
    #6 ee/EllisLab/Addons/moblog/mcp.moblog.php(914): Moblog->check_pop_moblog()
    #7 [internal function]: Moblog_mcp->check('1')
    #8 ee/EllisLab/ExpressionEngine/Controller/Addons/Addons.php(1662): call_user_func_array(Array, Array)
    #9 ee/EllisLab/ExpressionEngine/Controller/Addons/Addons.php(946): EllisLab\ExpressionEngine\Controller\Addons\Addons->getModuleSettings('moblog', 'check', Array)
    #10 [internal function]: EllisLab\ExpressionEngine\Controller\Addons\Addons->settings('moblog', 'check', '1')
    #11 ee/EllisLab/ExpressionEngine/Core/Core.php(241): call_user_func_array(Array, Array)
    #12 ee/EllisLab/ExpressionEngine/Core/Core.php(110): EllisLab\ExpressionEngine\Core\Core->runController(Array)
    #13 ee/EllisLab/ExpressionEngine/Boot/boot.php(151): EllisLab\ExpressionEngine\Core\Core->run(Object(EllisLab\ExpressionEngine\Core\Request))
    #14 public_html/admin.php(153): require_once('...')
    #14 public_html/admin.php(153): require_once('...') 

I also noticed that when I check the file upload directory, a small CPanel logo is added to the directory after every "check now" instance.

Any thoughts on what the error is indicating?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.