0

I'm upgrading my client's website from EE 2.5.5 to bring it up to current spec. I'm at the first stage, going from 2.5.5 to 2.11.9. The site has a number of modules, including CartThrob (currently 2.1.4). (It's all very old, I know.)

After running the EE upgrade, at the end of the installation wizard process I get an error message, and visiting the admin page I now get the following:

A PHP Error was encountered Severity: Notice

Message: Undefined property: Wizard::$functions

Filename: english/cartthrob_lang.php

Line Number: 650

Fatal error: Call to a member function insert_action_ids() on null in /path/to/system/expressionengine/third_party/cartthrob/language/english/cartthrob_lang.php on line 650

(server path hidden by me!)

Is this a basic incompatibility between the current version of CT and EE 2.11.9, so I'd need to upgrade CT before upgrading EE, or is there something else going on?

Also is there any general advice about upgrading EE and modules? Should the modules be upgraded first or does EE go first? I've searched the documentation and not found a clear answer.

Any help appreciated.

Cheers,

Crac

0

Check directly with add-on vendors for compatibility but most addons can be converted easlily.

ExpressionEngine 3 compatible third-party add-ons should be copied into the system/user/addons/ directory before upgrading.

Non compatible add-ons that you will not be using in v3 must be uninstalled and refactored out of your site before upgrading. ExpressionEngine 3 will not be able to run incompatible code to uninstall those add-ons after upgrading.

Upgrading from ExpressionEngine 2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.