1

So I've been a bad web master and have been using EE 1.7.3 since 1.7.3 was the new hotness. I never upgraded to 2 once it became paid, nor did I update to Core. As can be expected, this is now causing problems with PHP versions and so on. So I backed up my entire website and grabbed the latest version of EE, only to find that if you're upgrading pre-3 you need to do it manually from 2.

The problem is, I cannot find a version of EE 2 anywhere to download. My original plan was to try and go from version to version so I could do a steady upgrade, but that doesn't seem to be a viable option. Are there any instructions out there on how I should go about this upgrade? I know I can't hold off forever, but I really don't want to have to start over, either.

1
  • Is more question to add-ons which your site use than to EE as is. Can you publish a list of your modules/plugins/extensions? Thanks!
    – Max Lazar
    Sep 16 '19 at 23:48
2

You can get a version of EE 2 from here:

https://github.com/ExpressionEngine/ExpressionEngine/tree/2.10.1

Although it is not the most updated version of EE2 (which is 2.11.9), you can use that to update far enough that an EE5 version can pick up from there.

How to upgrade EE from such an old version is tough; I've only done 2.x to latest release, never 1.x. I answered another question where I put down thoughts and notes on upgrading from EE2 to EE5 here, which may be useful to you:

Upgrade a site from EE2 to EE5

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.