I am running EE 5.2.6 and I have repeated issues with getting logged out of the control panel when I am in the middle of working on an entry.

This issue happens so frequently I filed a Bug Report https://github.com/ExpressionEngine/ExpressionEngine/issues/286.

Derek said that the problem was not reproducible, yet I can reproduce it virtually every time I create an entry. I have set the site time zone in ExpressionEngine according to my local time zone. My computer is a Mac and the time is set automatically, so technically they should be in sync.

According to Derek, the control panel should not log out until after an hour of inactivity, yet I can be in the middle of a lengthy entry and suddenly without warning get logged out, losing all changes. I have turned revisions on, but they do not save regular enough to be of any use. I had three versions of today’s entry all from 4:06 pm. I was logged out at 5:00 pm losing all edits to the very lengthy entry.

I am happy to make any changes to my configuration - see image - if I can just get this problem solved. I would love to hear from anyone that has a functioning configuration.

enter image description here

1 Answer 1


Set the CP session type to 'Cookies only' tick the 'remember me' checkbox on login and that should keep you logged in the CP.

Try adding these values to your config, creating a prefix can sometimes help with being booted from the CP:

$config['cookie_domain'] = "";
$config['cookie_path'] = "";
$config['cookie_prefix'] = "myprefix";

You might also find this config line useful too, especially if you have trouble logging-in

$config['secure_forms'] = "n";

Also you can try adding some timing settings to the config too:

$config['cp_session_ttl'] = 14400;
$config['user_session_ttl'] = 3600; 
  • How long a working session do you maintain with this configuration?
    – forrest
    Sep 19, 2019 at 22:12
  • I applied your settings and the control panel has been active for more than 90 minutes. Thank you.
    – forrest
    Sep 23, 2019 at 18:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.