0

I have a page in which I'd like to put a Sharepoint link, unfortunately the link contains :x: (https://mysharepoint....sharepoint.com/:x:/s/....) and EE is rendering the :x: as ❌, in view source this is in Unicode ❌ which obviously doesn't work in a hyperlink.

I've tried disabling emojis with the following (as I don't need/want them anywhere on the site):

  • In config.php: $config['disable_emoji_shorthand'] = 'y';

  • In config.php: $config['enable_emoticons'] = 'n';

  • Control Panel->Content & Design->Enable emoticons? : Disabled

I still have the wretched ❌. Is there anywhere else I should be turning them off?

  • Are you using a URL/Text field for the URL or adding as an inline link? The colon is a reserved character so shouldn't normally be used in that context. – Bluedreamer Oct 8 at 22:51
  • It's in a Wigwam text field. Just checked the database and in there correctly. Unfortunately no chance that we could get Microsoft to change their link format. – Jon Rhoades Oct 8 at 23:03
  • Yes MS aren't going to change. I believe Wygwam saves special characters as entries, you could adding the "Entrities" Advanced setting in Wygwam to disable them, then re-add the link to see if it stops saving the Unicode characters. – Bluedreamer Oct 9 at 9:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.