0

Even if the default language is set in portuguese in the Control Panel, when a member receives an account activation email and click on it, the success message appears in english.

The member receives in his email box the activation link:

https://www.mysite.com/?ACT=190&id=SZMyPGQEmG

Once clicked an english message appears (normally should be in portuguese, because all the text are translated in this language):

enter image description here

For this kind of email box the activation link, the default language setting (portuguese) is not applied. To be in portuguese i have to translate this file:

system\ee\legacy\language\english\member_lang.php 

Is there a configuration in the Control Panel, or a System Configuration Overrides to insert inside config.php file, to activate the language setting about activation messages?

0

Are you saying the language pack installed isn't loading that lang file and is instead defaulting to English? I think this is the file and pack you need:

https://github.com/EllisLab/EE-Language-Brazilian-Portuguese/blob/master/system/user/language/pt-br/member_lang.php

Make sure to set the installed pack as the default language:

https://docs.expressionengine.com/latest/general/languages.html#installing-a-language-pack

https://docs.expressionengine.com/latest/general/languages.html#setting-the-default-language

  • Hi thanks for your reply. The pt-br language pack is installed and set as default language. Works very well in the control panel, error messages, except for email confirmation message. Even if the language pt-br is set as default language, the email confirmation message use the english one. – Stéphane Oct 11 at 18:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.