I'd like to be able to upload PPT files in the CP, but I'm getting the "File not allowed" error. Can anyone tell me how to resolve this? This is in EE5 5.3.0--all the solutions I've seen have been in the EE2 format.

I've tried adding this to mimes.php with no success:

$config['mime_whitelist_additions'] = array(

Then I refresh the CP and try again, getting the same error.

Any ideas?

  • I noticed that some PPT files upload file, however. So this PPT may actually be formatted differently, though it opens fine. Is there a solution to this, like allowing the file extension rather than mime type? Or is that a bad idea?
    – jphansen
    Jan 27, 2020 at 15:07

1 Answer 1


There are a few mime types for .ppt files, try adding these:

.ppt application/mspowerpoint

.ppt application/powerpoint

.ppt application/vnd.ms-powerpoint

.ppt application/x-mspowerpoint

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.