0

My other templates open fine from the EE backend, but when I try to open my layout template I get the following message:

Call to a member function getId() on null in [path]/ee/EllisLab/ExpressionEngine/Controller/Design/Template.php

I can see and open the template in my ftp program, but can't open it from inside of EE.

I'm running version 5.3.0

3
  • May not be very helpful, but have you tried editing the template via your FTP link and replacing the content with something anodyne (<h1>Hello World</h1>) and seeing if issue goes away? If it works, suggests the issue is in the content of your template, if it doesn't suggests an EE config / setup issue. Either way, to get more / better help usually helpful to include details of what version of EE you are having problems with in your question. HTH. – JCOGS Design Apr 25 '20 at 10:28
  • Thanks for the suggestion. Sill no go. Sorry about the missing version number. I updated the question to include it, which is 5.3.0 – Barry Parr Apr 26 '20 at 1:24
  • OK - perhaps you could explain how you use the "layout template" in your setup - might help us work out what might be going on. If it is plausible to, maybe also post the content of the template (or a link to a shared version of it)? – JCOGS Design Apr 26 '20 at 13:46
0

If the issue is not solved and other templates working fine. Then you can follow the below steps to solve the issue.

You will create the new layout template and update the content it by your current layout template and save new one. Delete the current layout which have the issue. Rename to the new layout.

I hope that your problem will be solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.