0

I have this weird problem where templates are sometimes saved and sometimes not. I would guess it has to do with a memory issue of some kind but I don't know where to look.

I run EE 5.3.2 fresh install on PHP 7.2

I don't get an error from EE but from the server. So maybe it's a server setting. But again, where to look? Please help me out.

This is the server error message I get in my browser:

Forbidden

You don't have permission to access /admin.php?/cp/design/template/edit/27 on this server.
www.websitename.nl
1

This sounds like a Mod Security issue. If your web host has strict mod_sec rules doing some things in EE can trigger them.

I'd suggest making the error happen, making a note of the it happens, then look in your server logs to see if a rule is being triggered - if that's the case you may need to disable one or two specific rules. If you can't access mod_sec then ask your host to investigate and disable those rules (a good web host will do this for you!).

| improve this answer | |
  • Thank you for your answer and your clear instructions, Bluedreamer. I will investigate and come back on this. – mcwhitey Jun 30 at 7:31
  • Looks like you were right. I found this in the logs: [Fri Jul 03 14:34:57.094565 2020] [:error] [pid 4103211:tid 140705863268096] [client 77.61.6.85:60599] [client 77.61.6.85] ModSecurity: Access denied with code 403 (phase 2). Pattern match "<\\\\?(?!xml\\\\s)" at ARGS:template_data etc... – mcwhitey Jul 3 at 12:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.